关注云服务器
相关知识分享

怎么禁用wordpress主题和插件的版本更新提示

自从用了wordpress来建站,安装的插件就有很多很多,也导致了经常进入后台的时候,好多更新提示,强迫症能忍吗?不能忍。但是更新以后发现,好多插件失灵了,要不就是前台页面错位了,那么有没有不用更新,又能禁用wordpress主题和插件的版本更新提示的办法呢?有的,云测速本身也是一个强迫症患者,所以找到了方法,一起来看下吧。

最最最简单的办法就是打开wordpress的主题或者wordpress插件的文件修改版本号,直接修改到999.999,大部分wordpress主题和wordpress插件都可以做到一劳永逸。但是这种方法不好的地方就是你需要一个个插件去更改,那么有更简单一点的办法吗?

答案是肯定的啦。

云测速提供两种方法:

方法一

简单粗暴的升级版,把下面这串代码添加到你的wordpress根目录的wp-config.php文件里:

define(‘DISALLOW_FILE_MODS’,true);

当然,这个方法有一个弊端,就是当你更新wordpress的版本以后,需要重新修改wp-config.php文件一次。

方法二

如果不方便修改wp-config.php文件,你可以把下面的代码添加到你的wordpress主题的functions.php文件里:

function filter_plugin_updates( $value ) {
unset( $value->response['plugin-directory/plugin-file.php'] );
return $value;
}
add_filter( ‘site_transient_update_plugins’, ‘filter_plugin_updates’ );

云测速比较推荐第二个方法,原因就是每当更新wordpress版本的时候不用重新再修改一次,毕竟主题更新比wordpress本身更新要少一些。

赞(0) 打赏
未经允许不得转载:云测速 » 怎么禁用wordpress主题和插件的版本更新提示

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者吧~

微信扫一扫打赏