关注云服务器
相关知识分享

wordpress5.2开始要求php版本最低为5.6+

昨天有个朋友在云测速留言,关于他安装wordpress遇到的问题,他用的php版本是5.3,然后安装时候会报错,我就想起去年底的时候wordpress说过:

对于已经运行WordPress 5.0的数百万个站点,85%使用PHP 5.6或更高版本。我们最近还发现,显示鼓励用户升级其PHP版本的通知非常有效。Yoast SEO在去年进行了实验,发现网站所有者将其PHP版本升级的速度是他们显示通知之前的两倍。

有鉴于此,我想建议在2019年4月,我们将最低PHP版本要求提高到5.6。选择保留在5.5或更低版本的网站仍会收到安全更新和可能的错误修复,但在升级到支持的PHP版本之前无法升级到最新的WordPress主要版本。

同样,我想建议在2019年4月,我们将最低MySQL版本要求提高到5.5。98.5%的WordPress 5.0网站使用的是MySQL 5.5及以上版本。

根据反馈和有效性,我们可以通过在2019年12月前将所需的PHP版本提升到7.0+。

5.2版本开始,wordpress安装环境的php版本最低要求为php5.6,目前wordpress的版本已经更新到了5.3,也开始支持php7.4了,所以建议大家可以把php版本升级一下,因为每个人的生产环境不同,也说不上具体哪个php版本更稳定,所以只能自己测试了。

云测速目前用的php版本是7.2,之前用php5.6版本的时候,wordpress后台会提示有一些不兼容,但是还是能用,所以我就进行了升级,把php版本给升级到了php7.2,使用上没有发现什么不同。

其实,云服务器现在很普及了,网站圈子变化是相当块的,服务器环境的版本更迭也很快,所以大家还是适应潮流吧~

赞(0) 打赏
未经允许不得转载:云测速 » wordpress5.2开始要求php版本最低为5.6+

评论 抢沙发

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址

觉得文章有用就打赏一下文章作者吧~

微信扫一扫打赏